GuardTek Issue

Incident Report for TrackForce

Monitoring

A fix has been implemented for this issue and we are monitoring the results - thank you for your patience while we were addressing the problem and we apologize for any disruption.
Posted Dec 05, 2025 - 18:31 CET

Investigating

We are aware of an ongoing issue with GuardTek and are actively working to restore full service as quickly as possible.
Posted Dec 05, 2025 - 17:36 CET